robcole.com Forum
June 23, 2018, 08:40:59 am
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Welcome to SMF For Free
 
  Home Help Search Gallery Staff List Login Register  
  Show Posts
Pages: [1]
1  Products And Services / ExifMeta Lightroom Plugin / Re: ExifMeta—Status: This plug-in is currently disabled… on: December 16, 2014, 02:34:22 am
Hello again.

Thanks for your input. After reading your "Getting Started" posting, I realized I have been using the PluginMgr and Plugin Extras incorrectly. This time I selected the test photos after making my metadata selections in PluginMgr and then went to PluginExtras following your instructions. This worked and the "rc Standard" metadata did show! Thinking I had achieved a successful completion I closed Lightroom without recommitting or viewing the log file. When I re-opened Lr metadata had reverted to default and rc Standard selections were long gone and the plugin was disabled. So, I updated ExifMeta to v5.8 and started again—

I have attached a PDF with the log (showing screen grabs and logged errors). I spent some time getting familiar with the log contents to get an understanding of things to look for in the future (a major firmware upgrade to my camera this month—oh boy!). I've also attached the diagnostic log. Maybe they will shed some light on this issue.

Again, thanks for your time, patience, and help!
SCC
2  Products And Services / ExifMeta Lightroom Plugin / Re: Problem downloading new update… on: December 15, 2014, 09:55:11 am
Sorry My Bad!! I missed where to look and have it now.
3  Products And Services / ExifMeta Lightroom Plugin / Re: ExifMeta—Status: This plug-in is currently disabled… on: December 15, 2014, 01:53:55 am
PS— I should have added this (and it makes me think the blank fields are a coding bug) the right column shows only category heading names (Composite, ExifiFD, ExifTool, Fujifilm), the right side data (across from the item names on the left side) is blank.
SCC
4  Products And Services / ExifMeta Lightroom Plugin / Re: ExifMeta—Status: This plug-in is currently disabled… on: December 15, 2014, 01:42:15 am
Thanks for your reply and clarification of "auto-update (most-selected photo)". I get how that functions though the wording on the panel didn't make it clear to me its core function (a switch for auto-update: ON / OFF).

—  PS - I assume by "rc Metadata" you mean the "RC Standard" metadata viewing preset.
That's right. I had a choice of RC Standard & RC Custom.

Regarding the right panel not being populated, when I initially ran the ExifMeta Metadata Selection, I had the button "include exif metadata as one big text block" selected and all the item names & data showed up in the right-side column which made for impossible reading. Below the right column text block was the left column list of item names with no data on the right. When I de-selected that button ("include exif metadata as one big text block") and re-"Committed", all that remained was the left column list of item names with no data on the right. That is where I am today. (I was able to select/copy it and paste in into a text document so I could study what items I really wanted to include.) The short version is that the data did exist, and hopefully still does. I guess this is why we run tests.

I did delete the "ExifMeta Updated" date for one of these selected test photos (that field is now blank). When you say: "run a manual update", what does that mean specifically?

Thanks again for your patience and input.
SCC
5  Products And Services / ExifMeta Lightroom Plugin / Problem downloading new update… on: December 15, 2014, 12:47:00 am
…I'm not finding the download link for the latest ExifMeta plugin update. When I click on "Click here to proceed to the ExifMeta Forum for downloading..." [http://robcole.smfforfree3.com/index.php/board,2.0.html], the download link is not showing anywhere on the "ExifMeta Lightroom Plugin" page.

I'm running Mac OS X Maverick and Lr5.7
I tried loading the webpage in both Safari and Firefox—no luck.

SCC
6  Products And Services / ExifMeta Lightroom Plugin / Re: ExifMeta—Status: This plug-in is currently disabled… on: December 15, 2014, 12:26:47 am
Hi Rob,

I've made some progress—ExifMeta is enabled but I must be doing something wrong as it doesn't appear to hold the exif data and after closing Lr and even restarting my MacBook the ExifMeta plugin often comes up disabled.

Last night, using Plugin Manager I experienced a series of difficulties:
• General Settings:
  - Metadata items is set to 20
  - each time I deselected "Enable auto-update most selected photo", I received an error message stating auto-update had stopped. (Reselecting started auto-update.)
  - I selected "auto-update selected photos." I used this for photos to run my "representative sample/test run".

• ExifMeta Metadata Selections:
  - I chose ExifMeta Metadata Selections using the first column checkboxes and using the last column, hid the items not wanted.
  - Clicking on the "Hide Boring Tags" button, I logged numeral "1" in the appropriate field.
  - I then clicked "Commit".

I then got the pane stating: "Metadata definitions and tag sets have changed. Your catalog must be updated." [AuthorTools section / "Reload Plugin" button.*

In Lr, I was able to see an option for "rc Metadata" in the Library/Metadata drop down box. In my first round of this endeavor, in the Metadata panel, I got
all of the option items listed in a single text box on the right side of the panel, followed by a list on the left-side of only the names of the chosen items but none of the specific data. — very weird!

Then before closing down the app and restarting my Mac and Lr, I followed my understanding of the pane (see above asterisk), I opened Plugin Manager and clicked the "Commit" button. I'm guessing this undid all my effort, because the next time I opened Lr and looked at the selected photos, the "rc Metadata had disappeared and the plugin was "disabled": very confusing. I'm stumped.

• Is there something I'm doing to cause the plugin to disable itself?

• Might this have anything to do with OS X Mavericks and the issue of a "bash script" to run "enabling access to assistive devices" (jacobsalmela.com)?

• Below is the text from the plugin diagnostic file.

I look forward to any light you can shed on what I might do next. I'm really hoping I can get this to work. ExifMeta a great tool for learning how to fine-tune my camera and I would also like to apply it when using my old legacy lenses.

SCC
=============
Here is the text from today's diagnostic file. (It doesn't appear to show anything from last night's efforts.)

2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Logger enabled.

2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   10.9.4 (x64)
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Number of CPUs: 2
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Memory size: 4294.967296 MB

2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Lightroom 5.7

2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Plugin name: rc Exif Meta
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Plugin path: /Applications/Adobe Photoshop Lightroom Addons/ExifMeta.lrplugin
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Plugin version: 5.7
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Toolkit ID: com.robcole.lightroom.ExifMeta
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Plugin enabled: false

2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Plugin username: _Anonymous_
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Platform support verified - certified for Windows+Mac
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Lightroom version support verified - certified for Lr3 to Lr5
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Switched to pref set Default backed by /Applications/Adobe Photoshop Lightroom Addons/ExifMeta.lrplugin/Preferences/Default.txt
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Elare plugin framework initialized.

2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Found ExifTool built-in with plugin.
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Plugin synchronous initialization completed.
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   
2014-12-14 22:32:30 com.robcole.lightroom.ExifMeta   INFO   Switched to pref set Default backed by /Applications/Adobe Photoshop Lightroom Addons/ExifMeta.lrplugin/Preferences/Default.txt
2014-12-14 22:32:31 com.robcole.lightroom.ExifMeta   INFO   Background state changed to: starting
2014-12-14 22:32:41 com.robcole.lightroom.ExifMeta   INFO   Asynchronous initialization completed successfully.
2014-12-14 22:32:41 com.robcole.lightroom.ExifMeta   INFO   Background state changed to: running
7  Products And Services / ExifMeta Lightroom Plugin / Re: ExifMeta—Status: This plug-in is currently disabled… on: November 14, 2014, 11:12:58 pm
Log file attached—
SCC
8  Products And Services / ExifMeta Lightroom Plugin / ExifMeta—Status: This plug-in is currently disabled… on: November 14, 2014, 11:01:54 pm
Hi Rob,

I'm running Lr5 on a MacBook (OS X 10.9.4). After downloading and installing ExifMeta, I'm getting the Lr Plug-in Mgr status shown in my subject line.

I have a Fujifilm X-T1 and would like to have better EXIF data available so I can compare shots and gain a better understanding of the camera's manual setting variables, particularly WB Mode and Film Simulation. I also am using several legacy manual lenses and would like to know what exif data might be available when using them.

I'm a novice and not a programmer. Here are my questions:

- How can I determine why ExifMeta is not functioning?

- ExifTools is downloaded. How do I verify if it is properly installed and functioning?

- I read "Bash Script: Enable Access to Assistive Devices Programmatically in OS X Mavericks 10.9.x – Simulate Keystrokes”
     (http://jacobsalmela.com/bash-script-enable-access-assistive-devices-programmatically-os-x-mavericks-10-9-x-simulate-keystrokes/)
   - Do I need to run this script if I am using Mavericks (OS X 10.9)?… if so,
       - how is this done? (which app is used?, Do I simply copy/paste the script into that app?)

Thank you,
SCC
Pages: [1]
Bookmark this site! | Upgrade This Forum
SMF For Free - Create your own Forum | Buy traffic for your forum/website

Powered by SMF | SMF © 2016, Simple Machines
Privacy Policy